R51 III, Handschalter, BJ 2013, Tempomat funktioniert nicht, Fehlercode P0581

Es gibt 34 Antworten in diesem Thema. Der letzte Beitrag () ist von jo6666.

  • Hallo,


    ich kann meiner Frau leider keinen Gefallen abschlagen. Insofern habe ich jetzt einen R51 III, der einer Freundin von meiner Frau gehört, demnächst wieder auf dem Hof stehen. Um den Haussegen zu wahren sollte ich das Problem besser beheben. Normalerweise schraube ich bevorzugt 6 und 8 Zylinder-Motoren von MB und alles was mit der W211er Baureihe zu tun hat. Insofern ist jedes Auto-Problem lösbar. Aber alles ein Frage der Zeit. So wie es aussieht, habe natürlich im Forum bereits gestöbert, könnt Ihr mir eine Menge Zeit ersparen. Vllt. könnt Ihr mir sagen, ob ich auf dem Holzweg bin

    Folgendes:
    - Tempomat funktioniert nicht. D.h., wenn ich den Set - Knopf am Lenkrad drücke passiert nix. Jedoch scheint der Knopf zu funktionieren, im KI geht das Symbol für die gesetzte Geschwindigkeit an, allerdings blinkt das Set-Zeichen
    - Eine Werkstatt hat vorn rechts den ABS-Sensor getauscht, weil der als Fehler eingetragen war. Als ich nachgeschaut habe, war der Fehler immer noch eingetragen, kann aber nicht sagen, ob der nur gespeichert ist bzw. aktuell. Werde ich beim nächsten Auslesen sehen.
    - Im Sommer habe ich das Getriebe runter genommen, um die verheizte Kupplung zu tauschen (3,5 Tonnen Boot per Trailer aus dem Wasser gezogen).
    - Eingetragener Fehlercode (Delphi): P0581 - Schalterstromkreis Tempomat sagt mir leider nix
    - Das ABS scheint im 2WD beim ersten Betätigen des Bremspedals kurz zu arbeiten (pulsen im Pedal), beim mehrmals-hintereinander-Bremspedal-treten passiert das nicht mehr

    Beim Durchforsten dieses wunderbaren Forums habe ich folgende mögliche Fehlerquellen gefunden:
    - Spiralkabel am Lenkstock
    - Auflageflächen Raddrehzahlsensoren (wenn ABS nicht richtig funktioniert, funktioniert Tempomat auch nicht richtig)
    - Neutralschalter am Getriebe
    - ASCD-Switch (Schalter) am Kupplungspedal
    - Motorhochlaufschalter neben der Spiegelverstellung

    - Kabelbruch am Hauptstecker hinter dem rechten Vorderrad (ABS-Sensoren)

    - ?


    Ich weiß jetzt nicht, ob das alles Sinn bei dem Modell hat. Sehe ich, wenn das Auto wieder da ist. Aber vllt. hat jemand Erfahrung mit dem Problem?


    Beste Grüße, jpebert

  • Hi Jan-Peter


    Sei begrüßt und willkommen !


    ich kann meiner Frau leider keinen Gefallen abschlagen.

    Das wäre vülleicht mal ne Übung wert, sonst ist man sehr schnell der AvD ( Affe vom Dienst ).

    Aber dabei kann ich Dir nicht helfen, das muss aus Dir heraus kommen.

    der einer Freundin von meiner Frau gehört,


    Das Spiel kenn ich nur zu gut, jahrelang geübt, wer Geld verschenkt oder für umme Auto repariert, hat immer viele "Freunde".


    habe natürlich im Forum bereits gestöbert


    Sehr gut ! Finde ich ganz toll, Du hast auch genau die Punkte gefunden um die es geht.

    Die meisten Newbies machen sich nicht die Mühe vor ihrer Anfrage mal zu recherchieren.


    ob der nur gespeichert ist bzw. aktuell. Werde ich beim nächsten Auslesen sehen.


    Ich tippe auf: noch aktuell, das würde sowohl die ABS-Geschichte auch die Tempomatsache erklären.


    Dann P0581, hier ne sehr gute Seite

    https://www.autocodes.com/search_codes.php?q=P0581

    Mich irritiert, dass dieser Fehler sowohl mit "Signal low-" als auch mit "Signal high-Voltage" bezeichnet wird .


    Entweder gibt das BCM wg ABS das Signal nicht frei oder es fehlt an Spannung, einfach mal die Sicherungen systematisch durchchecken.


    Die ABS-Sensoren an der Hinterachse lassen sich ganz leicht optisch auf "hoch gerostet" prüfen.

    Zulässiges Spaltmaß zwischen Sensor und ABS-Ring beträgt 0,3 bis 0,9mm.


    Der Leerlauferkennungsschalter wird ziemlich genau überwacht, da kämen weitere Fehlernummern wie P1706 / P1707


    Teste ob die restlichen Schalter am Lenkrad funktionieren, z.B. die fürs Radio.


    Berichte dann doch mal weiter, viel Erfolg.


    Grüße

    O.


    Zur Bedienung des Forums:

    Rechts oben die beiden Sprechblasen = Konversation = Pers.Nachrichten, weisse Ziffer in rotem Kreis = Anzahl Nachrichten für Dich

    Rechts daneben die Lupe = Suchfunktion

  • oggsi_eggdschen

    Du hast absolut recht ... Schuster, bleib bei Deinen Leisten ...


    Ich mache den Wagen nebenbei seit mehr als zwei Jahren und behebe auch jedes noch so kleine Problem, damit der in einem Tip-Top-Zustand ist. Allerdings ist Nissan halt nicht mein Spezialgebiet, d.h. jede Arbeit dauert mindestens 3x solange wie ich für MBs brauche und zweitens scheint die Dame das zum Anlass zu nehmen, mit Ihrem Wagen durch die Gegend zu reiten, als wäre ich gut bezahlt. Nachdem ich Ihr die Kupplung im Sommer gewechselt habe, wollte nicht hören, dass man kein 3,5t-Boot aus dem Wasser zieht bei schwierigen Gelände mit dem kleinen 4-Zylinder (140kw, Y25DDCi) und schon gar nicht mit Kupplung/Schaltgetriebe, habe ich quittiert. Die Dame konnte nicht mal auf ein Umrüstkit auf ein 1-Massenschwungrad warten, musste alles ganz schnell gehen und hat das Boot am nächsten Tag mit der nagelneuen-Kupplung und dem vermaledeiten Zweimassenschwungrad gezogen. Ich war fast am explodieren.

    Naja, das Mädchen wieder an der Backe, ich gehe auf dem Zahnfleisch. Aber zumindest etwas gutes hat das. Ich bin hier im Forum gelandet und habe was gelernt und einige gute Beiträge gefunden.


    Ich melde mich auf alle Fälle, wahrscheinlich nächste Woche und berichte ausführlichst. Herzlichen Dank für die Hilfe und Informationen!

  • Hallo jpebert,

    ich schließe mich in allen Punkten Oggsi an, nur hier muss ich widersprechen:

    Der Leerlauferkennungsschalter wird ziemlich genau überwacht, da kämen weitere Fehlernummern wie P1706 / P1707

    Ich behaupte das der Leerlaufschalter nicht überwacht wird und keine Fehlernummern kommen.

    Allerdings lässt sich dessen Funktion leicht prüfen:

    Funktioniert der "Motorhochlaufschalter" oder "Vorwärmschalter" im Leerlauf, d.h. die Drehzahl steigt, und fällt bei Einlegen eines Ganges dann ist dieser OK.


    Die Signale der Radsensoren lassen sich auch mit der App "Car Diagnostic Pro" und einem ODB2 Dongle mit ELM 327 oder gutem Clone ermitteln.

    https://car-diagnostic-pro.de.aptoide.com/app


    Fehler der Radsensoren ABS /ESP im Steuergerät verschwinden nach ein paar hundert Metern und einem Neustart von alleine wenn alles OK.


    DTC-Nr. Bezeichnung der Störungsdiagnose DTC-Erfassungszustand Mögliche Ursache
    P0580
    0580
    Stromkreis des
    ASCD-Lenkradschalters niedrig
    ● ECM erfasst, dass ASCD-Lenkradschalter in Stellung EIN verklemmt ist.
    ● Kabelstrang oder Steckverbinder
    (Stromkreis des Schalters ist unterbrochen oder kurzgeschlossen.)
    ● ASCD-Lenkradschalter
    ● ECM
    P0581
    0581
    Stromkreis des
    ASCD-Lenkradschalters hoch
    ● Ungewöhnlich hohes Spannungssignal wird von
    ASCD-Lenkradschalter zu ECM gesendet.


    Für die genauen Spannungswerte schick ich Dir nen Pdf.


    Jochen

  • Ich behaupte das der Leerlaufschalter nicht überwacht wird und keine Fehlernummern kommen.


    Hi Jochen

    Bin mit allem einverstanden was Du oben geschrieben hast, bis eben auf diesen Punkt.


    Die ECU muss und will "wissen" ob der Leerlauf eingelegt ist um die Leerlaufregelung zu aktivieren.

    Selbst schon gehabt, daher wusste ich auch die Nummer.


    Fehler P1706 Leerlauferkennungsschalter, einige Bildchen und Überlegungen


    Grüße

    O.

  • Oggsi - Du forderst mich heraus!

    Könnte man in der Tat meinen das der Leerlaufschalter für die Leerlaufregelung zuständig ist.

    Ist er aber nicht!

    Siehe EC-20 ff.

    Leerlauf ist wenn keiner aufs Gaspedal tritt.

    All die die einen defekten Leerlaufschalter hatten z.B. Dietmar und ich selbst werden bestätigen können das man damit problemlos weiterfahren kann - nur ohne Tempomatfunktion.


    Gruß

    Jochen


    P.S.

    Noch toller ist die Funktion des gleichen Schalters beim Terrano2 3l MT - der hat gar kein Tempomat. Hier dient er ausschließlich dazu ein überdrehen des Motors im Leerlauf zu verhindern.

    Ist er defekt - wird im normalen Fahrbetrieb die Drehzahl bei 3000 Touren abgeregelt. Die Lösung hierfür - Stecker vom Schalter abziehen.

  • Oggsi - Du forderst mich heraus!

    Aber nein, ich bin ein ganz netter, friedlicher und freundlicher Mensch*** und vermeide Streit wenn es denn irgend geht.


    Ich werde das mal durchlesen, aber nicht jetzt.


    Mit defektem Schalter kann man durchaus weiterfahren, hatte nicht gesagt, dass man das nicht könnte.


    Grüße

    O.



    *** z.B. kriegt meine Frau nur die Prügel, die sie auch wirklich verdient hat.

  • ......

    Leerlauf ist wenn keiner aufs Gaspedal tritt.

    All die die einen defekten Leerlaufschalter hatten z.B. Dietmar und ich selbst werden bestätigen können das man damit problemlos weiterfahren kann - nur ohne Tempomatfunktion.

    Gruß

    Jochen

    .........

    Also ich erinnere mich dunkel - ist ja schon ein Weilchen her -;) und habe auch mal die alte "Lebensakte" vom Ferkel, die noch in meinem Archiv schlummert, hervorgekramt.

    Ich hatte ja 2x das Problem mit dem Leerlaufpositionsschalter -im WHB als Park/Leerlaufstellungsschalter bezeichnet-, (beim ersten Mal etwas aufgearbeitet, beim zweiten Mal dann gewechselt) aber Fehlermeldungen wurden da in keinem Fall ausgegeben.

    Tempomat konnte man setzen, manchmal ging er, manchmal nicht, manchmal länger, manchmal kürzer. Ursächlich war in beiden Fällen immer der etwas "abgearbeitete" Kontaktstift, der praktisch die Gangstellung, also den Leerlauf ermittelt.

    Gruss Dietmar

    Bodenfreiheit und Drehmoment :perfekt:
    statt Tieferlegung und Spoiler


    Gruss Dietmar

  • Problem mit dem Leerlaufpositionsschalter -im WHB als Park/Leerlaufstellungsschalter bezeichnet-,...

    Tempomat konnte man setzen, manchmal ging er, manchmal nicht, manchmal länger, manchmal kürzer. Ursächlich war in beiden Fällen immer der etwas "abgearbeitete" Kontaktstift, der praktisch die Gangstellung, also den Leerlauf ermittelt.

    Genauso und nicht anders war es bei meinen Pathfinder ebenfalls; neuer Schalter rein und weg waren die Probleme mit dem Tempomat.

  • Guten Abend,

    so heute Auto hingestellt bekommen. Angemacht, ESP Off Lampe und die "Schleuderanzeige" war erst mal an, ging dann aus. Bin mit 2WD gefahren. Die Dame meinte später es wäre im 4WD-Automodus gekommen.

    Ausgelesen, Fehler Raddrehzahlsensor vorn rechts und P0581 - Tempomat Schalter. Raddrehzahlsensor ist neu, Radlager VR (Meyle) scheint i.O. hatte ich letztes Jahr getauscht. Sollte also auch so sein. Den Verteilerstecker für die Raddrehzahlsensoren vorn rechts am Rahmen scheint es bei dem Modell nicht zu geben. Das Kabel vom Raddrehzahlsensor VR geht direkt nach oben in einen Hauptkabelbaum in der Nähe vom Motorsteuergerät. Suche mir morgen die Pinbelegung des ABS-SGs raus und messe das Kabel durch. Möglicherweise hat ja doch der Impulsring im Radlager ein Problem, obwohl relativ neu. Aber vorher messe ich doch lieber mal das Kabel durch. Evtl. hat das ABS-SG (Pumpe) auch eine Macke. Die ließ sich ansteuern, ein Fehler war hinterher nicht eingetragen.


    Alle Fehler gelöscht und zu einer befreundeten Werkstatt gefahren mit einem ordentlichen Boschtester. Radrehzahlsensorfehler ist blöderweise nicht wieder aufgetreten. P0581 war wieder da, allerdings behauptet der Tester, dass irgendein Ventil in der Servolenkung einen zu hohen Eingangswiderstand. Naja, denke das ist nur eine fehlerhafte Beschreibung, Tempomat geht ja immer noch nicht.


    Der Tester hat allerdings das Getriebesteuergerät ausgelesen, was mein Tester nicht kann. Dort waren 4 Fehler eingetragen, alle ABS relevant. Die haben ich in das Werkstattprogrämmchen eingeben. Dort wurde als Fehlerursache die Bremslichtschalter, Cancelschalter Tempomat ausgegeben. Daraufhin habe ich jeweils die 2 Schalter am Bremspedal und am Kupplungspedal ausgebaut. Jeweils ein Schließer und ein Öffner. Durchgemessen, sind i.O. Wieder eingebaut auf Anschlag (einstellbar). Leider habe ich vorher nicht darauf geachtet, ob die vorher auch auf Anschlag eingebaut waren (muss so sein), da ich nicht wusste dass der Abstand einstellbar ist. Vielleicht funktioniert es ja wieder, teste ich morgen. Wahrscheinlich nicht.

    Da ich die Bremsen vorn morgen auch erneuere überprüfe ich auch gleich mal die Einbauposition vom Raddrehzahlsensor.


    Einen Schalter/Taster für die Anhebung der LL-Drehzahl hat der Wagen nicht. Zumindest habe ich keinen gefunden.


    Unter ABS/ESP ist selbst kein Fehler eingetragen, aber in der Sektion Allradelektronik (3.0) sind ein Haufen Fehler. Gibt es ein Allradelektronikmodul? Die Fehler deuten ja eher auf den ABS-Block (Steuergerät), was dann evtl. den Radrehzahlfehler und das nicht funktionierende Tempomatsystem sowie das kurze Eingreifen des ABS bei fast jeder Bremsung erklären könnte. Liege ich da richtig?


    p.s. Warum die Foto gedreht sind, weiß ich leider auch nicht. Habe versucht die entsprechend der falschen Ausrichtung zu drehen. Beim Hochladen werden die dann in irgendeine Richtung gedreht, habe aufgegeben, sorry.

  • vlt. hast du das Problem ja damit schon gefunden, denn ich wollte grade schreiben, dass es beim Nissan D40 und R51 öfter vorkommt, dass das Kupplungspedal nicht ganz retour kommt, die Leute es nicht merken und sich wundern wieso der Tempomat auf einmal nicht mehr geht (eben weil der Kupplungsschalter dann aktiviert ist).
    Ist auch bei mir schon passiert.

    Würde ausserdem empfehlen, den Bremskreis zu entlüften, beim Nissan läuft die Kupplung hier mit. Evtl. haben sich Luftblasen gebildet.

    Verstehe allerdings nicht, wieso du jemand anderem sein Auto so viel reparierst - hi & da ein Gefallen OK, aber entweder die Dame zahlt ordentlich sie soll in die Werkstatt fahren. Aber geht mich eh nix an.... :/

  • Danke! Schalter sind i.O. Beim Einbau - Abstand zu Hebel lässt sich einstellen, und sollte Null sein - passgenau eingesetzt. Hat also nix gebracht.


    Batterie aufgeladen, neue Bremsflüssigkeit rein (Kupplung, Bremse). Hat auch nichts gebracht.


    Ein Problem konnte ich aber lösen. Fehler Raddrehzahlsensor vorn / rechts. War unterrostet. Auflagefläche schön blank gemacht, danach kam der Fehler nicht mehr.


    Die Lenkradschalter Tempomat wollte ich testen, allerdings habe ich das falsche Werkstattbuch oder die Pinbelegung stimmt nicht. Klemme 102 sitzt im kleine Stecker des MSG (ECM). Dort sind die Plätze aber mit 1-64 nummeriert und zudem gibt es von den großen Pins nur 6 statt 8 wie im Werkstatthandbuch. Selbst wann man annimmt, dass nur die Nummerierung anders ist, an der Stelle wo die 102 ist, ist keine Hülse im Stecker. Beim großen Stecker fehlen die 5 gr. Pins gleich ganz. Offensichtlich passt das Werkstatthandbuch, zumindest elektrisch, nicht ganz.

    Dann wollte ich ganz clever sein und das Signal 102 direkt hinterm Lenkrad abgreifen, also Klemme 18. Aber auch die Stecker sahen komplett anders aus, so dass ich zunächst nicht weiterkomme, wenn ich nicht den richtigen Schaltplan habe. Ach ja, die 3 Massepunkte im Motorraum habe ich auch gereinigt, hat nix gebracht.


    Könnte mir jemand mit einem passenden Werkstattbuch oder dem Kapitel Motor, Abschnitt Motorsteuerungsanlage (EC.pdf), Absatz DTC P0580, P0581 ASCD-LENKUNGSSCHALTER aushelfen. Nissan Navarra geht sicherlich auch, die scheinen mir fast baugleich zu sein in dem Bereich.


    Schönes WE!

  • So, habe zu dem Thema einen alten, guten Schulfreund kontaktiert, der seit fast 30 Jahren als Meister in einer gr. Nissan/Opel - Werkstatt arbeitet. Gibt Euch und den Forum-Beiträgen in allen Punkten recht. Zusätzlich hat er noch den DPF ins Feld geworfen. Bei Problemen mit dem DPF wäre lt. seiner Aussage der Tempomat eines der ersten Systeme, die ausfallen. Ich checke demnächst, wenn der Wagen wieder da ist, ob der Beladungszustand zum Standardregenerierungsintervall passt. Er wusste es nicht mehr genau, meinte es müsste bei 1000km bzw. 1300km stehen.

    Naja, etwas langwierig, bin am Einkreisen, irgendwann hab ich dann wohl das Problemchen eng umzingelt. Werde berichten.

  • Bei einem vor Facelift würde ich einen Zusammenhang mit DPF ausschließen - bei den neumodischen Dingern halte ich es zumindest für unwahrscheinlich.

    Was ich bei Deiner Fehlersuche nicht verstehe:

    Sowohl die Signale vom Radsensor als auch die Lenkradtasten vom Tempomat, als auch den Leerlaufschalter kann man doch mit dem einfachen Icarsoft schon auslesen - Du scheinst doch Zugriff auf viel mächtigere Diagnosegeräte zu haben.

    Ein Werkstatthandbuch für ein FL Modell hat hier meines Wissens allerdings noch keiner.


    Gruß

    Jochen


    PS. Meyle Lager - gerade eingebaut - Schon unterrostet.... ts ts

  • Das mit den Diagnosen ist wahr. Allerdings bringt das immer nur etwas bis zu einem gewissen Punkt. Bspw. wenn Fehler Raddrehzahlsensor steht, geht es beim ABS/ESP-SG/Block los über Leitungen, Sensor selber, Auflageflächen, gebrochene/vorrottete Impulsringe, Dreck, bis hin zu Radlagerschäden. Da muss man dann halt selbst schauen und wissen, wonach man suchen muss. Die Diagnose hilft dann einfach nicht weiter.


    Das habe ich auch alles gemacht, was ging. Verschiedene Diagnosegeräte, auch Profidiagnosen + deren Möglichkeiten zur Prüfung und Ansteuerung. An eine Nissan-Diagnose könnte ich zu Not auch kommen, aber das wäre mit einer kleinen Reise verbunden. Klar zur Nissan Fachwerkstatt ginge auch. Aber wer will das schon, zumal ich nun bereits genug Diagnosen angehangen habe, aber ohne Messen und/oder Teileweitwurf nicht weiter komme. Auch in den Handbüchern steht fast überall messen, messen, messen weil die alten Pathfinder nun nicht alles mit Sensoren und Prüfschaltungen hinterlegt haben. Ist leider so.


    Dazu kommt noch, dass ich eigentlich ausschließlich MBs schraube, am liebsten Motoren, für deren Wagen ich alle möglichen Helferlein, auch elektronische, und damit einigen Ingenieur-technischen Reparatur-Komfort gewohnt bin, den m.E. kein anderer Hersteller bietet. Es fällt mir leicht schwer, mich durch das Eisenschwein Pathfinder durchzufuchsen ohne passend Schaltpläne. Sorry, bin eher ein Nissannovize, da geht alles nicht so gradlinig von der Hand weg. Fehlt mir die Erfahrung mit dem Auto, muss also immer eine grundsätzliche Klärung her, damit ich mir einigermaßen sicher bin, dass ich das richtige unternehme.


    Bin sehr dankbar für Eure Hinweise und Tips.

  • Hi,


    also was Radsensoren und Taster angeht - kann selbst das einfache iCarsoft, live - also während der Fahrt- die aktuellen Daten anzeigen. Also bei den ABS Sensoren einfach fahren und gucken, ob alle die gleiche Geschwindigkeit anzeigen.
    das gleiche gilt für die ganzen Taster und Schalter/ live anzeigen lassen und betätigen !?
    Erst wenn sich in diesem Verfahren zeigt, dass live Werte fehlerhaft sind - Stecker suchen/ Kabel durchmessen bis der fehlerhaft angezeigte Wert im Diagnosegerät wieder da ist/ stimmt.

    Sonst suchst Du Dir ja nen Wolf :)


    Olli

  • Danke, gestern nochmal einen Boschtester rangehangen. Keine Fehlereinträge mehr, bis auf P0581. Scheint also gefruchtet zu haben, die letzte Reparatur.


    Lenkradschalter Tempomat ausgelesen, live Werte. Das E/A-schalten des Tempomat/Begrenzers funktioniert laut KI, der Tester zeigt jedoch ein Dauer-EIN. ???

    Bei den anderen Schaltern steht ein Dauer-Aus, auch wenn man die betätigt.


    Bleibt nur Durchmessen vom ECM aus und dann noch mal an Stecker Taster Lenkrad in beide Richtungen. Es bleibt interessant. Schauen wir mal ob, es am Schalterblock liegt, des Spiralkabels oder doch was ganz anderes.